Skip to main content
Code42 Support

Code42 version policy

Applies to:
  • CrashPlan PROe
  • Code42 CrashPlan (previously CrashPlan PROe)

Overview

As described in the software version end-of-life policy, Code42 requires a minimum version for your Code42 environment. This article outlines specific versions currently required for Code42 software use, along with version end-of-life dates.

Applicable Code42 environments

This version policy applies to all Code42 environments with an on-premises authority server.

Supported versions

On-premesis 6.x authority servers

 

Version Release date End-of-life date Status Supported CrashPlan app versions CrashPlan mobile app versions
6.0 June 2017

December 20181

(projected)

Current

Windows, Mac, and Linux:

  • 6.0
  • 5.1.2 to 5.4.3
  • 4.5.2 to 4.8.3

Android: 5.2.1

 

iOS: 5.2

 

On-premesis 5.x authority servers

Version Release date End-of-life date Status Supported CrashPlan app versions CrashPlan mobile app versions
5.4.3 April 2017

May 20181

(projected)

Current

Windows, Mac, and Linux:

  • 5.1.2 to 5.4.3
  • 4.5.2 to 4.8.3

Android: 5.2.1

 

iOS: 5.2

5.4.2 March 2017

May 20181

(projected)

Current

Windows, Mac, and Linux:

  • 5.1.2 to 5.4.2
  • 4.5.2 to 4.8.2

Android: 5.2.1

 

iOS: 5.2

5.4.1 December 2016

May 20181

(projected)

Replaced by version 5.4.2.

Due to a known issue,

Code42 recommends upgrading immediately.

Windows, Mac, and Linux:

  • 5.1.2 to 5.4.1
  • 4.5.2 to 4.8.1

Android: 5.2.1

 

iOS: 5.2

5.4.0 November 2016

May 2018
(projected)

Replaced by version 5.4.1.

Due to a known issue,

Code42 recommends upgrading immediately.

 

Windows, Mac, and Linux:

  • 5.1.2 to 5.4.0
  • 4.5.2 to 4.8.0

Android: 5.2.1

 

iOS: 5.2

5.3.1 September 2016

January 20181

(projected)

Current

Windows, Mac, and Linux:

  • 5.3.1 to 5.2.0
  • 4.7.1 to 4.6.0

Android: 5.2.1

 

iOS: 5.2

5.3.0 July 2016

January 2018
(projected)

Replaced by version 5.3.1.

Due to a known issue,

Code42 recommends upgrading immediately.

 

Windows, Mac, and Linux:

  • 5.3.0 to 5.2.0
  • 4.7.0 to 4.6.0

Android: 5.2.1

 

iOS: 5.2

5.2.1 June 2016

November 20171

(projected)

Current

Windows, Mac, and Linux:

  • 5.2.1 to 5.1.2
  • 4.6.1 to 4.5.2

Android:

  • 5.2.1
  • 5.2

iOS:

  • 5.2
5.2.0.1 May 2016

November 20171

(projected)

 

Replaced by version 5.2.1.

Due to a known issue,

Code42

recommends upgrading immediately.

Windows, Mac, and Linux:

  • 5.2.0 to 5.1.2
  • 4.6.0 to 4.5.2

Android:

  • 5.2.1
  • 5.2

iOS:

  • 5.2
5.2.0 April 2016

November 2017
(projected)

 

Replaced by version 5.2.1.

Due to a known vulnerability,

Code42

recommends upgrading immediately.

Windows, Mac, and Linux:

  • 5.2.0 to 5.1.2
  • 4.6.0 to 4.5.2

Android:

  • 5.2.1
  • 5.2

iOS:

  • 5.2
5.1.2.1 January 2016

November 20171

(projected)

 

Current

Windows, Mac, and Linux:

  • 5.1.2 to 5.0.1
  • 4.5.2 to 4.4.1

Android:

  • 4.2.1
  • 4.2.0

iOS:

  • 4.2.0
5.1.2 January 2016

November 2017

(projected)

Replaced by version 5.1.2.1.

Due to a known vulnerability,

Code42

recommends upgrading immediately.

Windows, Mac, and Linux:

  • 5.1.2 to 5.0.1
  • 4.5.2 to 4.4.1

Android:

  • 4.2.1
  • 4.2.0

iOS:

  • 4.2.0

1 Based on the original release date of the 2-digit minor version

Unsupported versions

The versions listed in this table are no longer supported.

Authority server version Upgrade status

4.3.5

4.3.5.1

4.3.5.2

4.3.5.3

Upgrade to newer version by February 28, 2017

5.0.2

5.0.3

Upgrade to newer version by October 31, 2016
5.0.1 Upgrade to newer version by June 30, 2016

4.3.4
4.3.4.1

Upgrade to newer version by June 30, 2016
4.3.2
4.3.0

Upgrade to newer version before March 1, 2016.

Beginning March 1, 2016, the Code42 cloud stopped accepting connections from versions 4.3.2 and earlier. This means backups and restores to the Code42 cloud stopped working.

4.2.3.1
4.2.3
4.2.2
4.2.1
4.2.0
Upgrade to newer version before March 1, 2016
4.1.8.1 Upgrade to newer version by December 31, 2015
4.1.8 Upgrade to newer version by December 31, 2015
4.1.6.3 Upgrade to newer version by December 31, 2015
4.1.6 Upgrade to newer version by December 31, 2015
4.1.5.1 Upgrade to newer version by October 31, 2015
4.1.5 Upgrade to newer version by October 31, 2015
3.6.5.1 Upgrade to newer version by December 31, 2015
3.6.5 Upgrade to newer version by December 31, 2015
3.6.4.3 Upgrade to newer version by December 31, 2015
3.6.4.1 Upgrade to newer version by August 31, 2015
Upgrade date changed from October 31, 2015
3.6.4 Upgrade to newer version by August 31, 2015
4.1.4 Upgrade to newer version by June 30, 2015
3.6.3.2 Upgrade to newer version by April 30, 2015
3.6.3.1 Upgrade to newer version by April 30, 2015

Earlier than 3.6.3.1

Upgrade to newer version by February 28, 2015

 

  • Was this article helpful?