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This article applies to CrashPlan for Small Business.
Looking for information about Incydr or CrashPlan for Enterprise? Search or browse.

Incydr, no.

CrashPlan for Enterprise, no.

Code42 for Enterprise, no.

CrashPlan for Small Business, yes.

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Cannot open Code42 app due to uncaught exception error (CrashPlan for Small Business)

This article applies to CrashPlan for Small Business.
Looking for information about Incydr or CrashPlan for Enterprise? Search or browse.

Incydr, no.

CrashPlan for Enterprise, no.

Code42 for Enterprise, no.

CrashPlan for Small Business, yes.

 

Overview

This article describes a known issue resulting in an Uncaught exception error that prevents you from opening the Code42 app. This error appears when the Code42 app log directory has limited permissions.

To correct this problem, follow the steps below.

Affects

Windows, Mac, and Linux devices running the Code42 app with limited permissions on the Code42 app logs directory.

Considerations

Cause

When permissions on the Code42 app log directory are changed by the end user or third-party software, it can result in the Code42 app being unable to write to the log files in that directory. When the Code42 app runs a check on startup to verify that it can perform all its required tasks, it encounters the problem with being unable to write to the logs. The Code42 app then shows the Uncaught exception error that prevents the Code42 app from starting.

Diagnose

Verify the problem by viewing the permissions on the Code42 app log directory.

Windows

Mac

Linux

Contact Customer Champions
If permissions for the log directory appear normal, contact our Customer Champions for help with fixing the problem of not being able to open the Code42 app.

Recommended solution

On Windows and Mac, resolve the issue by changing permissions for the Code42 app logs directory. On Linux, resolve the issue by deleting the Code42 app logs directory. The Code42 app recreates it with the appropriate permissions the next time you launch the app as a user.

Windows

Mac

Linux

In rare instances, an issue with the ui.log file can cause an uncaught exception error. To resolve the issue, stop the Code42 service, delete the ui.log file (from the UI log file locations listed in the File and folder hierarchy article), and restart the Code42 service. After the service starts, a fresh ui.log file is created.