Skip to main content

Who is this article for?

Incydr Professional, Enterprise, Gov F2, and Horizon
Incydr Basic, Advanced, and Gov F1

Find your product plan in the Code42 console on the Account menu.
Not an Incydr customer? For CrashPlan articles, search or browse.

Instructor, no.

Incydr Professional, Enterprise, Gov F2, and Horizon, no.

Incydr Basic, Advanced, and Gov F1, yes.

CrashPlan Cloud, no.

Retired product plans, no.

CrashPlan for Small Business, no.

HOME
GETTING STARTED
RELEASE NOTES
FAQs
APIs
SYSTEM STATUS
Code42 Support

Code42 app system requirements

Who is this article for?

Incydr Professional, Enterprise, Gov F2, and Horizon
Incydr Basic, Advanced, and Gov F1

Find your product plan in the Code42 console on the Account menu.
Not an Incydr customer? For CrashPlan articles, search or browse.

Instructor, no.

Incydr Professional, Enterprise, Gov F2, and Horizon, no.

Incydr Basic, Advanced, and Gov F1, yes.

CrashPlan Cloud, no.

Retired product plans, no.

CrashPlan for Small Business, no.

Overview

This article lists system requirements for the Code42 app in Code42 environments licensed for Incydr Basic and Advanced.

For Incydr Professional, Enterprise, and Horizon, see Code42 platform hardware and software requirements.

Code42 app

  • These system requirements are the minimum requirements to install the Code42 app. Use more powerful hardware for the best performance.
  • The Code42 app is supported on Macs with the Apple M1 chip, but is not supported on other devices running ARM processors, which includes most phones and tablets.
  • If your backup is unusually large (more than 1 TB or 1 million files), you must configure the Code42 app to use more RAM than the minimum requirement.
  • The Code42 app requires an Internet connection for almost all activity, including signing in, backing up, restoring, and changing most settings. 
  • The Code42 app requires a graphical user interface (GUI) for use on all operating systems. The app's desktop UI typically requires a screen area at least 960 pixels wide by 780 pixels high. Some systems may be able to display it as small as 900 pixels by 680 pixels.

Following are the minimum requirements for devices running the Code42 app. However, depending on usage, the Code42 app may need more than the listed minimums to operate effectively.

OS Hardware Software
Windows
  • 2 GHz dual-core CPU
  • 2 GB memory
  • 2 GB drive space

Supported Windows operating systems for the devices in the Code42 cloud environment 

Mac

  • Apple M1 or 2 GHz 64-bit Intel CPU
  • 2 GB memory
  • 2 GB drive space

Supported Mac operating systems for devices in the Code42 cloud environment 

Linux
  • 2 GHz CPU
  • 2 GB memory
  • 2 GB drive space

Supported Linux operating systems for devices in the Code42 cloud environment1

 

Install:

  • libgconf-2-4
  • libXScrnSaver
  • net-tools
  • libnss3
  • libxss1 (Ubuntu 14.04 only) 
  • libnsl (Red Hat Enterprise Linux 8.1 and later only)

1 The Code42 app supports extended update support (EUS) versions of Red Hat Enterprise Linux and long-term support (LTS) versions of Ubuntu.

Previously supported operating system versions

For previously supported operating system versions, see our article on operating system support