Skip to main content

Who is this article for?

Code42 for EnterpriseSee product plans and features
CrashPlan for Small Business 

CrashPlan for Small Business, no.

Code42 for Enterprise, yes.

Link: Product plans and features.

This article applies to version 6.

Other available versions:

Version 5Link: What version am I on?

Code42 Support

Code42 app system requirements

Who is this article for?

Code42 for EnterpriseSee product plans and features
CrashPlan for Small Business 

CrashPlan for Small Business, no.

Code42 for Enterprise, yes.

Link: Product plans and features.

This article applies to version 6.

Other available versions:

Version 5Link: What version am I on?

Overview

The minimum system requirements below are for the current version of the Code42 app.

Code42 platform system requirements are also available for Code42 server administrators.

Code42 app

To avoid security risks, keep your operating system updated.

OS Hardware Software
Windows
  • 1 GHz dual-core CPU
  • 1 GB memory
  • 750 MB drive space

Windows operating systems:

  • Windows 10 Version 1809 - October 2018 Update
  • Windows 10 version 1803 - Spring Creators Update (Code42 app version 6.7.2 or later)
  • Windows 10 version 1709 - Fall Creators Update
  • Windows 10 version 1703 - Creators Update (Code42 app version 6.8 and earlier)
  • Windows 8.1
  • Windows 7

Mac

  • 1 GHz 64-bit Intel CPU
  • 1 GB memory
  • 750 MB drive space

Mac operating systems:

  • macOS Mojave 10.14 (Code42 app version 6.5 or later)
  • macOS High Sierra 10.13
  • macOS Sierra 10.12
  • OS X El Capitan 10.11 (Code42 app version 6.8 and earlier)
  • OS X Yosemite 10.10 (Code42 app version 6.0.4 and earlier)
Linux
  • 1 GHz CPU
  • 1 GB memory
  • 750 MB drive space

Linux operating systems:1

  • Red Hat Enterprise Linux 7.6 (Code42 app version 6.5 or later)
  • Red Hat Enterprise Linux 7.5
  • Red Hat Enterprise Linux 7.4 
  • Red Hat Enterprise Linux 7.3 (Code42 app version 6.8 and earlier)
  • Ubuntu 18.04
  • Ubuntu 16.04
  • Ubuntu 14.04

Install:

  • libgconf-2-4
  • libXScrnSaver
  • net-tools
  • libnss3
  • libxss1 (Ubuntu 14.04 only) 

1 The Code42 app supports extended update support (EUS) versions of Red Hat Enterprise Linux and long-term support (LTS) versions of Ubuntu. Currently, EUS versions of Red Hat Enterprise Linux and LTS versions of Ubuntu use glibc 2.27 or earlier.

The Code42 app requires a graphical user interface (GUI) for use on all operating systems. The app's desktop UI typically requires a screen area at least 960 pixels wide by 780 pixels high. Some systems may be able to display it as small as 900 pixels by 680 pixels.

Previously supported operating system versions

The following operating systems were previously supported for the Code42 app, but are no longer supported.

Operating system Last supported Code42 app version
Red Hat Enterprise Linux 7.3 6.8
Windows 10 version 1703 - Creators Update 6.8
OS X El Capitan 10.11  6.8
Windows Server 2012 and 2012 R21 4.8 and 5.4
Windows Server 2008 R2 4.8 and 5.4
Windows Server 2008 4.7
Windows Vista Service Pack 2

4.7

Windows XP

4.7

Windows Server 2003 and 2003 R2 4.2
OS X Mavericks 10.9 4.8
OS X Mountain Lion 10.8

4.7

OS X Lion 10.7

4.7

Mac OS X Snow Leopard 10.6 4.22
Mac OS X Leopard 10.5 3.6.4
Mac OS X Tiger 10.4 3.2

Red Hat Enterprise Linux 6.9

4.8 and 5.4
Red Hat Enterprise Linux 6.8 4.8 and 5.4
Red Hat Enterprise Linux 6.7 4.8 and 5.4

1 Windows Server 2012 R2 was the last supported Windows Server OS. Windows 2016 was never supported.
Some computers running version 4.2 automatically upgraded to version 4.3. Computers that automatically upgraded were supported through version 4.3.