LDAP connection problem
Who is this article for?
Instructor, no.
Incydr Professional, Enterprise, Horizon, and Gov F2, no.
Incydr Basic, Advanced, and Gov F1, no.
CrashPlan Cloud, no.
Retired product plans, yes.
CrashPlan for Small Business, no.
Overview
This article explains how to interpret and respond to the following alert.
The table below displays where the alert appears and where it can be configured.
Alert Text | Location |
"Problem with connection to LDAP server: server URL" | Delivered by email and to the Alerts Overview of the Code42 console |
"LDAP connection problem" | Settings > Notifications of the Code42 console |
Severity
Warning - although this alert indicates a serious issue that should be addressed, it does not pose an immediate risk of data loss, security breach, or service interruption. If the problem is not corrected, however, more severe problems could occur.
Cause
This alert is triggered when the authority server is unable to connect to a configured LDAP server.
Possible effects
- Users unable to authenticate again if deauthorized
- New users cannot be activated using LDAP authentication
- Automatic user deactivation by LDAP active script will not function
- User management using the active script, org name, and role scripts will not function
Before you begin
You should have a good understanding of LDAP and how LDAP is integrated into the Code42 environment.
Recommended solution
To resolve this alert:
- Note the hostname or IP address of the LDAP server affected, as given by the alert
- Check the status of the LDAP server:
- Is the server powered on?
- Can you ping the LDAP server from the command line of the authority server?
- Is the LDAP server process running?
- Check your authority server's LDAP configuration from Server > Settings > Security > LDAP
Acknowledge the alert
An alert appears in the Code42 console's list of active alerts until someone dismisses it. To dismiss an alert:
- (Version 6.5 and later) Go to Active Alerts, select the alert, then go to the action menu and choose Dismiss.
- (Before version 6.5) Go to Alerts Overview, select the alert, then go to the action menu and choose Acknowledge.