Scheduled Job: Service Provider Certificate Renewal on server has failed
Who is this article for?
Incydr, no.
CrashPlan for Enterprise, yes.
Code42 for Enterprise, yes.
CrashPlan for Small Business, no.
This article applies to on-premises authority servers.
Overview
This article explains how to interpret and respond to the following alert. The table below displays where the alert appears:
Alert Text | Location |
"Scheduled Job: Service Provider Certificate Renewal on server <sever name> has failed." | Alerts Overview of the Code42 console |
Severity
Cause
At startup, the authority server creates self-signed realm and IdP (identity provider) certificates (used for authentication) if they do not already exist; these expire in 5 years. If these certificates are within 6 months of expiration, the authority server attempts to renew them. This alert appears if the authority server cannot renew the certificates.
Potential effects
If the realm and IdP certificates expire, you cannot sign in to the Code42 console or the Code42 app.
Recommended solution
This problem is likely caused by database corruption. Contact Code42 for Enterprise support to resolve this issue.