Skip to main content
Code42 Support

Import CSV reports to Microsoft Excel

Available in:

  • CrashPlan PRO
    • Standard
    • Premium
    • Enterprise
Applies to:

Overview

Exporting data from your Code42 environment to a CSV file provides the flexibility to generate your own customized reports from raw data. However, some spreadsheet applications, including Microsoft Excel, may make undesirable changes to data types when importing CSV files with the default settings.

This tutorial explains how to:

  • Export report information from the administration console and Code42 web apps to a CSV file
  • Import the CSV file to Microsoft Excel while preserving data types and number formats

Steps

In some spreadsheet applications, including Excel, opening the CSV file may default to displaying longer numbers in scientific notation format (for example, 6.60805E+17). Follow the steps below to prevent this formatting.

  1. Navigate to the screen containing the Code42 data you want to export.
    • From an administration console detail screen, select Export All from the action menu.
    • From a Code42 web app, click Export All As CSV.
      The CSV file is generated and downloads.
  2. Open Microsoft Excel.
  3. Open the Import Wizard:
    • Windows: From the Data tab, select Get External Data > From Text.
    • OS X: Open a new workbook. Select File > Import and choose CSV file.
  4. Choose the downloaded CSV file.
    The Text Import Wizard opens.
  5. In Step 1, select Delimited, then click Next.
  6. In Step 2, select Comma as the delimiter, then click Next.
  7. In Step 3, select all columns with large numeric entries you want to review (for example, version, deviceUid, userUid).
    Hold down the Shift key to select multiple adjacent columns. To select non-adjacent columns, repeat steps 7 and 8 for each column.
  8. Change the column data format from General to Text.
  9. Select Finish.

Microsoft Excel Text Import Wizard

Horizontally scrolling on OS X
If you are unable to scroll left-to-right in the Import Wizard on OS X:
  1. Go to System Preferences > General.
  2. Next to Show scroll bars, select Always.

External resources

  • Was this article helpful?