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Code42 Support

Troubleshoot seeding to your private cloud

Applies to:
  • Code42 CrashPlan (previously CrashPlan PROe)

Overview

This article provides solutions for any issues that may arise during the process of seeding archives to your private cloud.

Affects

Any Code42 server used for seeding archives

Diagnosing

Code42 server sends an email notification

Issue

If there is a problem during the seeding process, the Code42 server sends an email to the address configured in that server's c42.seed.email system property. The affected seed archive is renamed <GUID>.SEED_FAILED.<timestamp> and placed in the seeding directory that was used for the seeding process. For example:

CrashPlanArchive_SEED/578290134123758901.SEED_FAILED.1358867950197

Recommended solution

The recommended solution depends on the type of message included in the notification:

Error Message Cause Solutions
Computer not found The device does not exist within the master server's database. Backup archives created under another Code42 environment (with a different master server) cannot be seeded.
  • Seed the correct archive.
  • Back up the device normally without seeding.
Destination not offered The device being seeded is not allowed to back up to the destination that is being seeded. Enable backup to the destination via the organization level or system-wide level destination settings.
Unknown destination error The master server cannot gather information about the destination where the seeded archive has been placed. Confirm network connectivity between the master server and the destination.
Unreadable file

The Code42 server cannot read the seed archive.

  • Confirm that the copied seed archive is the same size as the original archive.
  • Confirm that file permissions on the seed archive are correct.
System error The seeding process has failed for another reason. System errors also include a stack trace for additional diagnostic information.

Contact our Customer Champions for Code42 CrashPlan support or CrashPlan for Small Business (previously CrashPlan PRO) support.

Seeded archives do not move

Issue

Archives placed in the seeding directories are not immediately processed by the Code42 server.

Cause

The Code42 server checks every five minutes for archives in each seeding directory. A backup archive in the seeding directories is moved only after the backup archive remains the same size for two consecutive seed checks. This ensures that the archive has been completely copied into the seeding directory before the Code42 server moves it to the store point.

Recommended solution

Wait up to ten minutes before the seeding job begins moving a seeded backup archive from the seeding directory to the associated store point.

If the archive has not moved after ten minutes, contact our Customer Champions for Code42 CrashPlan support or CrashPlan for Small Business support.

Seeded archives do not exist on the store point

Issue

Seeded archives are not present on the store point after seeding is complete.

Cause

If data balancing is enabled on the store point the archive is being seeded to, the data balancing process may move a seeded archive to another store point immediately after seeding is complete.

Solution

Use the administration console to search for the archive's GUID on all store points:

  1. Sign in to your administration console.
  2. Enter the archive's GUID in the search box.
  3. Select the result listed under Devices.
  4. Select the device entry to view its details, including the destination and store point on which the archive is stored.

Seeding performance is slow

Issue

Seeding archives takes longer than expected.

Cause

Archive maintenance occurs on an archive immediately after the completion of the copy operation.

Solution

In order to speed up archive maintenance, you may choose to allocate more of your Code42 server's processing resources to archive maintenance.

  1. Sign in to your administration console.
  2. Navigate to Destinations > Servers.
  3. For each server that is being used to seed archives:
    1. Click the server entry to view its details.
    2. From the action menu, select Edit.
    3. Increase the slider for Maintenance Rate, User Jobs to allocate more processing resources for archive maintenance.
Maintenance setting
Changing this setting affects the maintenance jobs that the Code42 server runs daily. If you change this setting, we recommend reverting the change when your seeding process is complete.
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